Mittwoch, 9. April 2014

Yet Another Heartbleed post

Well, as i spended hours on the heartbleed bug currently, i just need to tell you this:

Update your openssl libary now!

I guess the bug could be one of the most urgent bugs we had.

What you should do:

And dont forget to restart your apache/nginx/lighttpd/postfix/whatever server. 

As i normally maintain a higher range of ip addresses i just wrote a short script

Step 1: fping -g IPRANGE > ips.txt
Step2:  sh test.sh > test.txt 
#!/bin/bash
for line in `cat ips.txt | cut -d ' ' -f1`
do
        ./heartbleeder $line:443
done;
Step 3: login to the server and solve the issue

have fun!